WordPress 3.2 richiede MySQL 5.0

La nuova versione di WordPress, la 3.2 “Gershwin”, richiede la versione 5.0 di MySQL per la gestione del database.
Se il tuo blog non è molto vecchio sicuramente avrai già la 5.0 installata.
Se invece il tuo blog, come il mio, ha un bel po’ di anni allora ci sta che tu abbia una versione precedente di MySQL. Io avevo la 4.1 e il messaggio “impossibile aggiornare”, lì per lì mi ha un po’ preoccupato. In realtà non è stato poi così difficile ovviare a questo piccolo problema.

I passi, in sostanza, sono stati questi:

  • fare un bel back-up di tutto
  • creare un nuovo database versione 5.0 dal pannello di controllo dell’hosting
  • esportare e scaricare in locale una copia del DB attuale
  • importare il file .sql appena creato nel nuovo DB
  • cambiare il file “wp-config.php” facendolo collegare al nuovo DB (devi conoscere il nome utente, la password, il nome del nuovo DB e il nome del server che lo ospita)

Il mio fornitore di hosting è register.it che usa PHPmyadmin come interfaccia di gestione dei database.
Nel caso il tuo fornitore di hosting non dia la possibilità di creare nuovi DB però la faccenda diventa impraticabile e devi contattare direttamente loro per chiedere un aggiornamento del MySQL.
Ovviamente puoi anche aspettare ad aggiornare WordPress, il nuovo admin non aggiunge nessuna funzionalità indispensabile, è progettato prevalentemente per essere più leggero e veloce, come loro stessi dichiarano.
La versione italiana non è ancora stata rilasciata.